Primitive not implemented in this virtual machine

Trying to follow along with the book and I'm on 2.9 - Alarm Clock. The second set of code is giving me this error when I press the go button.


  • Hi,

    Can you tell me what version of MicroBlocks you are using? In this topic, you can read how to check that.

    Could you try this version also?

  • Thanks for the reply Peter. The version is 1.1.89


  • PeterMathijssen
    edited November 2022

    What version of the virtual machine is on your board? Did you use my ubp file? For me, this one works.

  • When ı try Peter's ubp files, it works. I have version 1.1.89 too

  • Since the error points to the virtual machine on the board, it is important to show what version you have. How to find the virtual machine version is explained in this topic.

  • Hi,

    Here, both "when started" and "when <cond>" scripts run simultaneously. Both try to initialize OLED library. This is not good and not needed.

    Init OLED only once in "when started".

    In the other when script, provide a very small wait ms to delay running.

    We have revised all project codes and will post updates very soon.

  • Hi @Turgut, forgot about the OLED block. 😁 This was also exactly the same project that I did the first time I start using my PicoBricks and just followed the tutorial. Great that you are reworking them.

  • Powderjockey
    edited November 2022

    Firmware version is v170. I tried your sketch and received the same error. I noticed the "WhenStart", I am using the greater than and you have the lesser than. The book also shows the Greater than.

    Your sketch appears to function now after I did another firmware update, I think to v170.

  • On another quick not, is the red LED suppose to be on all the time? It doesn't matter what sketch follow, the LED is on.

  • Great that it is working now. The red LED is not used in this script. Could it be that it was used by another script and wasn't turned off?

  • Turgut
    edited November 2022


    None of the modules get reset when a new program starts, or a processor reset is done with the button. This is something Robotistan will review as an improvement.

    In the meantime, if you unplug the USB cable and power down the entire board, all should reset.

  • Turgut
    edited November 2022

    Sorry to all experiencing problems with sketches, and environment version updates. We are in a very rapid back to back improvement cycle trying to implement changes and also solve the coding issues.

    All 25 projects have been revised and improved. Will be updated on the GITHUB very soon. And we'll post a notice for the new versions, so you know what you are downloading.

    It is very important that you check your running version against the web site latest postings and do an update to the MicroBlocks web app and the corresponding firmware. If you make habit of running the MB IDE from the web site RUN link, followed by a firmware update check, you should be OK. After that, you only need to check the numbers and don't need to update unless the numbers have changed.

    And always post both numbers when you report problems, and request help.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!