My Computer isn't Recognizing the Main Board

Hi, I have a 2014 Macbook Pro Running OS 11.6.5,

I loaded Micro Blocks onto my computer and plugged in the board (holding down the Bootsel button) and it wasn't recognized. I tried this numerous times, attempting to connect the drive via Microblocks, but the board was never recognized as a drive. I also tried to connect it with different cords. No luck. I'm not sure if I need to type something into Terminal for the drive to be recognized. If so, please let me know.


  • Hi, Just a quick follow-up: After doing a little more research, this person describes a similar issue between the Raspberry Pico and a Macbook. Any insight is greatly appreciated

  • Not Yet. I was hoping someone from Robotsian would chime in. I also called their Delaware number (which is now disconnected) and emailed their form (they didn't answer). Please let me know if you have any suggestions.

  • Could you try it on a Windows computer? Just in case

  • Hi, The computers I have are all Macintosh. Can you please confirm that the Pico Bricks system was tested on Intel Macs?

    I've tried to connect the Raspberry Pi board with Micro Blocks, Thonny and PyCharm. It doesn't seem to connect with the provided cable (I'm not sure if this cable has been adequately tested). I used another cable and the board occasionally connects and then disconnects. The behavior is similar to what's described in this Stack Overflow post:

    In one of the answers to the question, a programmer used PicoTool to reset the Flash Memory. That may be what's necessary in this case, but I'm not an experienced enough programmer to do it. Is it possible to send a replacement board that's been tested on an Intel Mac? Do you have any representatives in the U.S.?

    Thank you for your help.

  • Hi,

    We both tested on Intel and ARM Mac devices although it is not relevant since the Pico is manufactured by Raspberry Pi. Also the Raspberry Pi Pico is pre-programmed and tested before we send it to you.

    There is a way to reset the Flash Memory without PicoTool but you have to get access Pico's memory by pressing and holding the BOOTSEL button before you plug-in the USB cable. If you can reach the Flash Memory, I can forward you to the flash reset firmware.

    Also Can you please check without using PicoBricks, just unplug the Raspberry Pi Pico from PicoBricks board? If that works we can send another PicoBricks to you, otherwise we can send a brand new Raspberry Pi Pico.

    By the way we are from Robotistan team both SametS and me.

    Have a nice day

  • Hi, I just want to share an update on my issue in case anyone else encounters it. I eventually was able to connect my main board to a Windows computer and it immediately recognized it. The setup was fairly straightforward. My mac now recognizes the board and I'm working my way through the projects with my son. I'm not sure if these boards have been set up to connect with Macs, at least not initially. It may make sense to do further testing.

  • I know this may sound lame, and ypou tried different cables, but this system seems to be very picky abut the cable. The short, shielded cable that comes wit the kit may be your best bet. I have tried pther cables, and they give intermittent performance. All USB cables are NOT the same. Some work really well as charging cables, but poorly as data cables. I have had this problem with the Rasberry Pi as well.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!