Picoboard not working after update


I received my Picoboard and got very excited. Hooked it up to my MacBook and followed the instructions to connect and update it with MicroBlocks. But after the update it stopped working. Then I hooked it up to a PC. Same thing happened again.

Now it does not show up as a device if I connect it while holding down BOOTSEL on either machines. And Microblocks or Thonny does not find it regardless of if BOOTSEL is pressed or not on connect.

Please advice


  • Hello,

    I'm facing the same issue.

    Yesterday, after the update, it was working, I played with it for 30 minutes.

    Then, this morning, it is not recognised anymore by the iMac (holding BOOTSEL or not).

    Any advice or solution for us ?


  • Hi,

    I'm having a similar issue.

    I got to the point where microblocks asked to connect the board holding the BOOTSEL button to be able to update the firmware, which I did. The board got detected as an usb device, I selected the PICO firmware, but no much feedback from microblocks from that point on. Pressing Connect showed the port, but selecting it would not do anything.

    I then tried to reconnect a couple of times with and without BOOTSEL, but no joy, the system doesn't detect the board as USB since.

    I tried on both Win10 and Ubuntu, meanwhile no issue connecting an usb stick or a phone.

    Please let me know how to proceed!

    Thank you in advance!

  • chuantey
    edited October 2022

  • SametS
    edited October 2022

    Hello Guys;

    Those who have this problem, can you send an e-mail to [email protected] and write the backer numbers?


  • Hi,

    To help all of you to sort out the problem, let's review the two way you can connect a PICO to the computer:

    1. BOOTSEL button pressed and then plugged into the USB port
    2. Plugged into the USB without pressing the BOOTSEL button.

    #1 will show up in the Windows Device Mgr as a disk drive, named: RPI RP2 USB Device

    This is the method you should use to do a PICO firmware update from MicroBlocks.

    Important point to remember - you need to:

    • UNPLUG the PICO from the USB port
    • Press and hold the BOOTSEL button
    • And while holding it down, plug it into the USB port.
    • At the moment you plug it in, you should hear a system sound indicating the USB port activation and subsequently the PICO should appear as a drive in your Windows system.
    • Now you can let go of the button and proceed to firmware update.

    #2 will show up in the Windows Device Mgr as a COM port, named: USB serial Device (COMnn). nn will vary in each system.

    This method is used when programming the PICO from the MicroBlocks IDE.

    Now, the problem reported: Pico not being visible or working within the system in either mode might be due to several things:

    Pico is not visible as a drive when plugged as in #1 above, or as a COM port when plugged in as in #2 above could be a hardware issue, as it has to do with assignment of drive or port status from Windows. the PICO board might be bad, or Windows might be having a problem activating the board. Contact Robotistan to assist you in resolving the issue.

    Referring to "not working after update" might be interpreted / caused by one of the following:

    If by "not working any more", you mean that when you first plugged PICO in, you were getting the environmental statistics display on the OLED screen; but after the update of MicroBlocks firmware, it did not display any more; this is normal. The initial display is done by a burned in program when the PICO was shipped. Once you do a firmware update, you overwrite this original program and there is no program running to display the stats. At this point, the PICO is ready to be programmed by you from scratch or via one of the examples in the Guide provided.

    A simple test you can do immediately is to get into MicroBlocks and click the USB icon and make sure you have a green USB connection icon.

    Then select the "set user LED <true>" block. Click it and you should see the LED on the PICO light up.

    If you cannot get the USB icon to go green, then you need to make sure the firmware on the PICO is up-to-date or installed at all (new boards will not have it installed). Go through the firmware update and try the USB connect icon again. If you get it to go green, then you should be able to program it.

    If you have a green USB icon, then you can also get a display of the IDE and firmware versions by selecting about from the wheel icon menu. You should see something like:

    Report these numbers when you are asking for assistance to enable us to help you better.

    I hope this sequence of trouble-shooting will help you identify if the problem is a bad hardware or a problematic firmware update.


  • Hi! I got some external help and it turns out the raspberry pico was the issue. Everything was working after replacing it. Thank you for your support!

  • I have discovered that this system is very picky about the USB cable. Some work, some don't. The short, shielded cable supplied with the kit is perhaps the best bet.

  • What worked for me was when updating the firmware, it asks if it's the wifi wersion, say No and install, then it should connect.

  • Turgut
    edited November 2022


    Thanks for this. When I wrote the Oct.21 post above, I forgot to mention that Pico has two models: the plain one and the (W) WIFI model.

    We support both of them. And when the firmware load is requested, it asks for confirmation of which one it is. For plain Pico's, one should always answer the question with a "NO".


    With the latest release of the MicroBlocks IDE, we have added a separate PICO-W to the list of devices to make it clearer and easier to select the right one. Please note the new menu and use accordingly:

  • I've been getting help with installing Thonny. I keep getting Error. I've been sent the rp2-pico-20220618-v1.19.1.uf2 file but I'm waiting to find out where to put it so that it could be recognized.

    Nevertheless, I've checked your above directions,

    Using #1, I get


    this I guess is working ok



Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!