RGB LED not lighting up

Im working though the eBook using Thonny and micro python. I can make the buzzer play music, the pico board led light up, the red led light up, use the button, Display things on the OLED. But the rgb led on GP6 does not light up at all. The test.py script doesn’t light it up either. I can hear the relay click, so I think that’s working too; although, Inhavent attached anything to it yet.

i think the rgb led iS bad. How can I get a replacement ?


  • Hi kayakbabe;

    Can you send an e-mail ( [email protected]) describing your problem with the backer number?

  • I don't use micropython myself. Just thinking with you. Is this the test code you used?


    I am guessing you haven't broken your PicoBricks apart? You could use a connecting cable to bridge directly to your main board from the RGB LED. This way you could test if there was some fabrication fault or if the RGB is faulty.

  • No, I don't want to break it up. It's too convenient. I have separate pico's to use when I want to finalize a project. The whole thing about the picobricks that attracted me was that it was all in one and easy to move around without losing parts to a project. It has most of the things I'd want for prototyping. When I saw this on kickstarter, I never intended to break it apart.

    Would it be possible to test it, If i remove the pico from the board then use the connectors to attach it to a stand alone pico?

  • I did send an email and I linked to this page.

  • kayakbabe
    edited December 2022

    I tested by linking the pico brick from the label ws2812 gp6 (right next to the pico) with a cable to the rgb led module and I tried it from both ends of the small rgb led brick. Still not lighting up at all.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!