HC05 Not Working

Trying to code the voice controlled robot car. Connecting the HC05 module, most of the time no lights come on on the module, occasionally the lights do come on. Even when the lights are on using either of the apps on the ebook can't see the HC05 on my android phone to connect to it.

What am I missing???


  • PeterMathijssen
    edited November 2022

    I have a Pixel 4a. I had to hold my phone really close to the module to pair it. I couldn't find it from 1,5 meters away. After that it was ok.

  • Is that even with no lights on on the module? It seems very intermittent if the lights are even on.

  • I never used a Bluetooth module before. Do the lights always have to be on?

  • I don't know that answer, I've never used one either. Hoping someone who has can also weigh in. Will try again tomorrow with my phone closer and follow up here.

  • Turgut
    edited November 2022

    HC-05 Users,

    You cannot use the module blindly. Need to know what state it is in and its default settings.

    Normally, the module will have a RESET button on it to put it into CONFIG mode.

    Pressing the button, insert it into the BT slot on picobricks as shown in the picture below.

    You either have a 6-pin module or a 4-pin module.

    6-pin module inserts one pin into each slot.

    4-pin module needs to be inserted into the CENTER four pins, leaving the two edge pins unused.

    You should have a Red LED blinking at 2sec intervals. That indicates you are in the CONFIG mode. Config mode operates at 38400 baud.

    Now we need to check out the settings of the HC05 :

    Load the MicroBlocks program for the Voice Controlled Robot Car.

    Modify the WHEN STARTED script to look like below, or drag and drop the script picture onto the IDE:

    Now we need to add the following block from the COMM group onto the IDE:

    If you don't see the COMM group, enable "show advanced blocks" from Settings (the wheel).

    We are going to enter AT commands into the first text area of the block and click on it to transmit.

    Responses will be shown in the running WHEN STARTED block.

    Click on the When started block to execute it. It is in a loop, waiting for responses from the HC05.

    Type "AT" into the text area (without the quotes) and click on the block. You should get an OK from the unit.

    If this does not work, your setup is not right, or your HC05 is not inserted right, or defective.

    If you have gotten an OK to the first transmission, let's continue:

    Type in "AT+NAME=HC-05" and click on the block. This sets the unit name to HC-05.

    You should see OK as a response.

    Now we check the operation mode: Type in "AT+ROLE?" and click on the block.

    You should see +ROLE:0 OK, meaning the unit is in SLAVE mode.

    Now we check the unit password: Type in "AT+PSWD?" and receive hopefully 1234.

    This is the default.

    If you get something else, change it to 1234 with AT+PSWD="1234". You need quotes around the pswd.

    Now you should get an OK.

    Then verify the password with "AT+PSWD?" and get back what you entered.

    Then we need to check the interface speed: Transmit "AT+UART?"

    You should get: +UART:115200,0,0 OK.

    You might get different speeds shown. Whatever you get, we need to change it to 9600 to work with the mobile APP.

    Send "AT+UART=9600,0,0" and receive OK.

    Afterwards you can verify again by redoing the previous AT+UART? command.

    It should show +UART:9600,0,0.

    If you have successfully done all that, you should be ready to communicate with it from the APP.

    Power cycle your board,

    Your HC-05 unit RED LED will be flashing rapidly, indicating it is operating normal.

    When you link to it from the APP, the RED LED will be flashing two times every five secs. This is the normal communication mode.

    Your unit name is HC-05 and should show up in the Android BT list.

    Pair to it and use password 1234 when asked.

    Reload the original Voice Controlled Robot Car script into the MicroBlocks IDE.

    Run the Mobile APP.

    Hope this is helpful for you to get started.

  • While you are running the mobile APP, observe the RED LED.

    It should be in two flashes every five sec mode for normal operation, while transmitting the car commands.

    If it switches to the rapid flash mode, then the APP has lost connection with the HC-05.

    You can re-connect from the APP and it should be back to normal.

  • Where does one find the blue tooth is libraries. Can't see serial open command.

    Also pressing reset as I insert HC-05 does not do anything ... no red-light flashing. So can continue as I'm not in config mode.



  • Disregard my last Tx. As soon as I read to use advanced blocks, I tried that.... All is good.



  • Still don't see red light on inserting HC-05 with reset depressed.



  • Tried following all of the instructions above. Red and blue lights flash rapidly and then go solid when holding reset button while connecting the module.

    Moved forward anyway, got an "OK" on the step when entering "AT". But all steps after only get "OK" response, no matter what is entered in the serial write and red and blue stay solid the entire time???

  • @wfortuny, @barriereg

    What model of Bluetooth module do you have? Maybe on the packaging there is a notation.

    My writeup is specific to HC-05, HC-06.

    The fact that you are getting an OK means you somehow entered the Config mode, but light indicators are not as expected. This could be due to a different model of BT module.

    Important thing is to verify good operation of the BT module. This will be hard to do from within the project code.

    Much better option is to connect the BT module using a USB2Serial converter, which might not be readily available, and a terminal program on the Win PC.

    There is another indirect way to test the connection.

    Power up your setup normally with BT module in.

    Go to your Android cell phone and open up BT options and see if your BT module is listed there.

    If it is, at least it is operational and you can PAIR to it.

    If no BT module is shown, you might have a defective unit.

    If you do see your module, PAIR to it and try the project at 9600 baud setting.

    If you leave my modified code with the "say cmd" block within the loop and a 1sec wait, you should see any messages coming in from the mobile voice control APP.

    If you see garbled input, baud rate is wrong in the BT module.

    Yes, this was a very long-winded post, but comms troubleshooting over forum postings is not an easy thing to do.

    I can try to assist over a video conference link, if your schedules permit.

    You can contact me over my email, to free up this space. My timezone is GMT+3.

  • Hi again,

    My model is HC05 on package. There are no markings on physical module.

    I don't see red light blink. I don't get ok;

    I don't see it appear on my phone to pair. I'm using Apple SE cell.

    I'll touch base with you on E-mail



  • @barriereg

    This link will help you maybe: The issue is the Apple cell !


    I will not be able assist you in a zoom call given the hardware combo.

    If you do have access to an Android phone, then if things do not work, let me know and we'll work on it.

    I am simply not an Apple knowledgeable person. And the project requires a download of a Voice APP from the Google Playstore anyway.


  • @barriereg

    Sorry about my previous reply. I just realized there were two parts to your problem:

    • HC-05 working or not
    • use of Apple cell

    I can in fact help you with the first one. Let's have a call. Contact me on my email to arrange a time.

  • I believe the module I have is an HC05, it came withy picobricks kit.

    When I power on the picobrick and the lights are solid, occasionally I can see HC05 in available Bluetooth devices, but when I click to connect to it on my android phone it just says can't connect and doesn't ask for a pairing code.

  • @wfortuny

    Did you try getting into config mode?

  • I tried seeing the HC05 (for pairing) with our android Samsung Galaxy 5. Does not see it.

    I performed the reset and plug in of the HC05. No red light.

    I do not see any evidence of this unit working.

    please advise



  • Yes I did. Same process as before.

    Tried following all of the instructions above. Red and blue lights flash rapidly and then go solid when holding reset button while connecting the module.

    Moved forward anyway, got an "OK" on the step when entering "AT". But all steps after only get "OK" response, no matter what is entered in the serial write and red and blue stay solid the entire time???

  • @barriereg , @wfortuny

    Let's try a zoom call when it is suitable to you. Send me your times via email. Remember I'm in timezone GMT+3 and can be available till 11pm my time.

    If we cannot make it work, we'll ask robotistan to send you two new HC05 units.

  • Even if the datasheet and all manuals claims that it runs on 3.3V and 5V power levels, we experimented some HC06 modules does not run on 3V3. FYI the ESP8266 is not 5V tolerant. Thats why we used 3V3 at IoT Expansion board. Thank you

  • The HC-05 board indicates a range of operation of 3.6-6.0 Vdc. With USB connected V+ to gnd (at Bluetooth socket) measured 3.3Vdc. Same across 3V3 - gnd on main board (as it's the same connection). With this connection my HC-05 does not power up.

    Connected 5 Vdc (Main Board VBus - gnd) via mini bread board and male jumpers to HC-05 (HC-05 plugged into mini board). HC-05 powers up and works perfectly. Thanks, Turgut, Mehmet.

    Comparing 3 - AA battery housing power to USB power, measured the following:

    4.87 Vdc Main board Vbus-gnd (4.74 Vdc USB powered)

    3.25 Vdc Main Board 3V3 pin - gnd (3.24 Vdc USB powered)

    4.64 Vdc Main board pin 3v3EN - gnd (4.5 Vdc USB powered)



  • I'll send an email now, thank you.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!