Pico Bricks Not Working

Hi there. I bought a Pico Brick from Kickstarter. I tried to connect Pico Brick to my PC (running Windows 10) and it was not recognized by Windows (and could not be found from Thonny). Then I tried to separate the Raspberry board from Pico Brick and connect only the Raspberry board to my PC. This time my PC has no problem connecting the Raspberry board to my PC and Thonny also recognize the board. I would like to know if there is any problem of the Pico Bricks and how to fix it. Many thanks!


Best Answer

  • ozerngg
    Accepted Answer

    Hello @Albert_Wong

    Can you take a high-resolution and both side photo of the board both with Raspberry Pi Pico and without Raspberry Pi Pico attached and share it with us?



  • Does the red light come on (to the right of the USB connector on the white PicoBricks board) when you connect it through the USB to your computer? What happens when you press the 'reset' (red button on the white PicoBricks board below the green Pico board)? And finally what happens when you connect the Pico board to the USB cable when the white Bootsel button is pressed?

    I had a similar problem, until I used the short shielded USB cable that came with the kit. Some other USB cables do not seem to work, they are meant for power only, but they have a very poor data line.

  • Hi there,

    Thanks for your advice.

    Yes the right light is on. Nothing happened when I press the reset button and I am using the cable comes with the kit.

    Will try another cable ...


  • Albert_Wong
    edited October 2022


    High-res photos attached, thanks!

  • Hi Albert,

    Can you please e-mail [email protected] with your backer number? So that we can send you a new pair?


Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!